Subject: Re: NetBSD compat* packages
To: NetBSD Packages Technical Discussion List <>
From: David Laight <>
List: tech-pkg
Date: 08/16/2007 23:10:19
On Thu, Aug 16, 2007 at 05:57:13PM -0400, Johnny C. Lam wrote:
> If you are running NetBSD-3.0 and you would like to run a NetBSD-1.4 
> binary, then you would install compat14, compat15, compat16 and 
> compat20, which would provide the complete set of shared libraries needed.

Why is this needed?
The current libraries (usually) contain compat functions for old programs.

You might want to look at some way of setting the 'emul root' if you
want some processes to use different libraries (or other files).


David Laight: