Subject: Re: Mesa 7.0.1 update/recent commit
To: Dieter Baron <>
From: Alistair Crooks <>
List: tech-pkg
Date: 08/14/2007 11:41:53
On Mon, Aug 13, 2007 at 02:58:46PM +0200, Dieter Baron wrote:
> In article <> Alistair wrote:
> : On Mon, Aug 13, 2007 at 01:18:34AM +0200, Joerg Sonnenberger wrote:
> : FWIW, I think we need new Mesa7-based packages in addition to our
> : existing Mesa6-based ones, and to gradually migrate apps to 7 as
> : and when we can.
>   That only works well if versions 6 & 7 can be installed
> simultaneously.  Is that the case?  Or do we have to make that
> possible within pkgsrc?

We've had incompatible packages (usually different versions)
sitting side by side in pkgsrc for a long time. There are
various reasons for this (differences in database layout with
postgresql and aide), different licences (coda, probably others),
different maintainers, etc

>   Also, all concerns raised by Blair were about the update itself, not
> about incompatibilities with packages depending on Mesa.  Are there
> incompatibilities (to be expected)?

Not that I know of, but reverting the update and doing it in a
controlled manner would be my preferred option. I don't see any
reason to do a Big Bang approach to upgrading this one, but you
obviously know something I don't, so I'll trust your judgement
on this one. I would like it coordinated with other changes
that Blair has in the works, though.