Subject: Re: make replace still broken - losing +REQUIRED_BY
To: None <>
From: Joerg Sonnenberger <>
List: tech-pkg
Date: 08/10/2007 23:25:00
On Fri, Aug 10, 2007 at 06:27:00PM +0200, Joerg Sonnenberger wrote:
> On Fri, Aug 10, 2007 at 11:08:48AM -0400, Greg Troxel wrote:
> > I noticed that 'make replace' was not marking depending packages
> > unsafe_depends, and found that in addition +REQUIRED_BY is going away
> > across a make replace.
> You might find the attached script handy for the second part of the
> problem. I'll sit down next week and add that functionality directly to
> pkg_admin.

Scratch the "next week" part and use pkg_install-20070810. The new
rebuild-tree option does this.