Subject: Re: pkg_install versions and when it's needed?
To: None <>
From: Joerg Sonnenberger <>
List: tech-pkg
Date: 08/10/2007 19:02:13
On Fri, Aug 10, 2007 at 09:35:17AM -0400, Greg Troxel wrote:
> 2) Sometimes pkgsrc says a newer version is needed.  This can happen on
> older systems (nebsd-3 from 3.0, I think).  Then pkg_install is
> installed from pkgsrc.  If this is a bad version (meaning one that
> doesn't work right), and then one cvs updates, pkgsrc won't
> automatically install the newer pkg_install because the old one has a
> recent enough version compared to what's required.

FYI, there are pullups for the 20070804 version of pkg_install and
libarchive, at least the infrastructure, to netbsd-4. Once those are
settled in, the glue will follow as well as careful updates.

I plan to update NetBSD HEAD's version as soon as I am reasonable sure
that no reported unresolved problems remain. The only problem I am
currently aware that is unresolved is the "make replace" issue where it
doesn't handle the preserved files correctly and I don't think that is
the fault of pkg_install.