Subject: Re: Depending on a particular version of an emulation package
To: NetBSD Packages Technical Discussion List <>
From: Matthias Scheler <>
List: tech-pkg
Date: 07/31/2007 14:46:47
On Mon, Jul 30, 2007 at 05:30:49PM -0400, Johnny C. Lam wrote:
> >I have a new problem with it:
> >firefox-bin-java only exists for linux-i386 (because firefox-bin only
> >exists for it); it depends on sun-jre15, for which both linux-i386 and
> >linux-x86_64 versions exist. On NetBSD/amd64, the linux-x86_64 version
> >is built by default. So installing firefox-bin-java pulls in the
> >x86_64 version of the Java plugin and expects it to work in
> >firefox-bin.
> I wonder if for firefox (and seamonkey), this might be worked around by 
> appropriately depending on nspluginwrapper?

"nspluginwrapper" doesn't accept Sun's Java Plugin (not even under Linux).

	Kind regards

Matthias Scheler