Subject: Re: Removal of koffice-i18n-* packages
To: Mark Davies <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 06/08/2007 09:22:38
On Sat, 9 Jun 2007, Mark Davies wrote:

> I'd like to remove all the koffice-i18n-* packages as they are now 
> very old - they belong to koffice 1.3.5 and we are now up to 1.6.3.
> If someone wants a particular language for which there isn't currently 
> a koffice-l10n-* package they can send-pr or email me and I'll create 
> it - I just don't feel like creating and maintaining 39 packages for 
> all the languages if there is no demand.
> Any objections?
> cheers
> mark

Sounds fine to me. But you may want to ask on pkgsrc-users also to see 
which ones are used or needed. And also indicate when you will be 
removing the packages.

Also I recall we had a procedure for how and when packages can be removed 
but I don't see it documented.

- if there is a maintainer, email them about it first (this isn't for you)

- choose a date such as immediately before branch or immediately after 
  next branch or other

- post to pkgsrc-users with list of packages, reasons and timeline.

Once we decide on basic steps, I will add it to the documentation.

  Jeremy C. Reed