Subject: Re: bootstrap doesn't complie under interix 3.5
To: Vit Gottwald <>
From: Todd Vierling <>
List: tech-pkg
Date: 02/10/2007 17:14:23
On 2/9/07, Vit Gottwald <> wrote:
> Today I installed Interix and applied pattches according to the documentation
> form and
> I downloaded the stable version
> (pkgsrc-2006Q4.tar.gz) and tried to run bootstrap.

I'll look into this.

> The I tried the current version
> (bootstrap-pkgsrc-Interix-3.5-i386-20061106.tar.gz) with the same result.

That is a *binary* bootstrap package, which I actually highly
recommend -- by using it, you don't have to run bootstrap at all!
Just extract it to / and it creates /usr/pkg with the bootstrapped
tools ready to run.

Note, however, that there's a considerable amount of Interix breakage
otherwise in the 2006Q4 pkgsrc branch.  I would recommend going with
pkgsrc-current for Interix, at least until 2007Q1 is branched in

-- Todd Vierling <> <> <>