Subject: Re: subversion-base problems and apr version degrading (Re: [PATCH] devel/apr* www/apache2* revamp)
To: None <>
From: Bernd Ernesti <>
List: tech-pkg
Date: 01/25/2007 08:32:11
On Wed, Jan 24, 2007 at 11:01:37PM -0800, Eric Gillespie wrote:
> Bernd Ernesti <> writes:
> > There was an apr package with this version:
> > 
> > apr-     Apache Portable Runtime
> > 
> > which was installed on my system during a normal build.
> > 
> > It may not be a real apr version, but we had this version in pkgsrc.
> It was a mistake.  I am not sure of the correct course of action
> with respect to apr- out there.  As there could easily
> be a real, i do not think using something like that for
> the new packages would be appropriate, even if it weren't misleading.

Yeah, I also have no real idea how to handle it.

> > Is it possible to install both apr versions at the same time?
> Unfortunately no; they install at least one file without a
> versioned filename: lib/apr.exp .

Hmm, then there are some CONFLICTS lines missing and installing
apache22 makes it impossible to use subversion.