Subject: Re: subversion-base problems and apr version degrading (Re: [PATCH] devel/apr* www/apache2* revamp)
To: None <>
From: Eric Gillespie <>
List: tech-pkg
Date: 01/24/2007 23:40:24
Bernd Ernesti <> writes:

> > > Is it possible to install both apr versions at the same time?
> > 
> > Unfortunately no; they install at least one file without a
> > versioned filename: lib/apr.exp .
> Hmm, then there are some CONFLICTS lines missing

devel/apr0 and devel/apr both install the same package, different
versions.  devel/apr-util requires apr >= 1.2.8.  So, i don't
think any CONFLICTS are needed.

> installing apache22 makes it impossible to use subversion.

Not anymore; i just finished testing PKG_OPTIONS.subversion=apr1
to support this, and committed it.  Of course, if you naively
install subversion and then try to naively install apache22 (or
vice versa), it won't work.  I explained earlier why i think this
is the proper default behavior (though i'm not certain, and can
be convinced otherwise).

Eric Gillespie <*>