Subject: Re: subversion-base problems and apr version degrading (Re: [PATCH] devel/apr* www/apache2* revamp)
To: None <>
From: Eric Gillespie <>
List: tech-pkg
Date: 01/24/2007 22:38:53
Bernd Ernesti <> writes:

> And now subversion-base doesn't build, not to mention that the apr version

I tested it on my systems; sorry about the breakage.

> was degraded from to 1.2.8.

There is no such thing as apr{,-util}  That's an
artifact of a hack i used in the old devel/apr carried over to
the devel/apr1 package.

> [..]
> => Required installed package apr>= apr-1.2.8 found
> [..]
> checking APR version... 1.2.8
> configure: Apache Portable Runtime Utility (APRUTIL) library configuration
> checking for APR-util... configure: error: the --with-apr-util parameter is incorrect. It must specify an install prefix, a build directory, or an apu-config file.

Ah, i think i need to add <1.0 to the apr0 buildlink depends.

> Why does subversion-base needs apr0?
> I had no problem to build it with

I've asked on tech-pkg at least once before for opinions on this
issue.  With my Subversion project hat on, i say that we make a
guarantee not to break the ABI in the 1.x series.  apr 1.x has a
different ABI from 0.9.x.  So, we can allow people to build with
1.x, but we shouldn't ship binaries like that.

With my user hat on, i couldn't care less.  I build my own
software and have no interest in proprietary binary blobs.  I
want to use 1.2.8.

With my pkgsrc hat on, i don't know what to do.  Should pkg*src*
care about ABI compatibility?  What about the binaries NetBSD ships?

So, i punted and stuck with apr 0.x.

I'll go ahead and commit my PKG_OPTIONS.subversion support for
building with apr 1.x; i was holding that back with my ra-serf
changes, but i don't know what i was thinking.  That at least
will give you the option to build with 1.x.

I still think we should leave apr0 the default, but i am not
really sure yet.

Eric Gillespie <*>