Subject: Re: Apache and APR problem
To: John Klos <>
From: Todd Vierling <>
List: tech-pkg
Date: 01/23/2007 14:19:39
On 1/22/07, John Klos <> wrote:
> I just tried to do a "make update" in devel/apr (as updating Apache from
> 2.2.3 to 2.2.4 doesn't update apr). It deinstalled apr 1.2.8 and Apache,
> then started installing apr-

You wanted "devel/apr1".  devel/apr is not a multi-version package.

> This also brings to light the fact that we STILL don't have an easy way to
> tell people how to figure out what would be the most efficient top-down
> way to update.

If you [the user] understand how shlib versioning works, "make
replace" is your friend.  If not, "not my department."  (But yes, it's

-- Todd Vierling <> <> <>