Subject: Re: Running GTK+ applications without X11 under Mac OS X
To: None <>
From: Matthias Scheler <>
List: tech-pkg
Date: 01/16/2007 15:23:05
On Tue, Jan 16, 2007 at 04:09:20PM +0100, Julio M. Merino Vidal wrote:
> >Almost. It's "PKG_BUILD_OPTIONS.gtk2+". Thanks for the hint. I managed
> >to get "xchat" to build with a Quartz GTK+ now. But "avidemux2" can
> >probably not be build that way because it uses X11 functionality all
> >over the place I'm now trying to build "gimp" and "wireshark".
> Are you uploading these changes to pkgsrc?

1.) I've committed the fix for the "xchat" package.
2.) The "wireshark" package built without problems.
3.) "gimp" failed to build. This might be fixable because GIMP works under
    Win32 without X11 AFAIK.
4.) "avidemux2" might be fixable, too. But it seems to assume that building
    under Unix means that X11 is available.

I guess we need a way to install a non-X11 GTK+ and a X11 GTK+ package
at the same. Packages which work without X11 (e.g. "xchat" or "wireshark")
would use the non-X11 version by default.

	Kind regards

Matthias Scheler