Subject: security/libgpg-error fails on Solaris
To: None <>
From: Ulrich Habel <>
List: tech-pkg
Date: 11/04/2006 09:37:27
Content-Type: multipart/mixed; boundary="Kj7319i9nmIyA2yE"
Content-Disposition: inline

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I am using HEAD pkgsrc on Solaris 9, sparc using SUN Studio 11 compilers
and encounter the following problem when trying to build
security/libgpg-error in the configure phase:

--- listing start ---

bash-2.05# bmake configure
=3D> Required installed package digest>=3D20010302: digest-20060826 found
=3D=3D=3D> Checking for vulnerabilities in libgpg-error-1.4nb1
=3D> Checksum SHA1 OK for libgpg-error-1.4.tar.gz
=3D> Checksum RMD160 OK for libgpg-error-1.4.tar.gz
=3D=3D=3D> Installing dependencies for libgpg-error-1.4nb1
=3D> Required installed package libtool-base>=3D1.5.22nb3:
libtool-base-1.5.22nb3 found
=3D> Required installed package gawk>=3D3.1.1: gawk-3.1.5nb1 found
=3D> Required installed package gettext-lib>=3D0.14.5: gettext-lib-0.14.6
=3D> Required installed package libiconv>=3D1.9.1nb4: libiconv-1.10nb3 found
=3D=3D=3D> Overriding tools for libgpg-error-1.4nb1
=3D=3D=3D> Extracting for libgpg-error-1.4nb1
=3D=3D=3D> Patching for libgpg-error-1.4nb1
=3D> Applying pkgsrc patches for libgpg-error-1.4nb1
=3D=3D=3D> Creating toolchain wrappers for libgpg-error-1.4nb1
=3D=3D=3D> Configuring for libgpg-error-1.4nb1
=3D> Modifying GNU configure scripts to avoid --recheck
=3D> Replacing config-guess with pkgsrc versions
=3D> Replacing config-sub with pkgsrc versions
=3D> Fixing locale directory references.
configure: WARNING: If you wanted to set the --build type, don't use
    If a cross compiler is detected then cross compile mode will be
    checking for a BSD-compatible install... /usr/ucb/install -c -o root
    -g root
    checking whether build environment is sane... yes
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking how to run the C++ preprocessor... cpp
configure: error: C++ preprocessor "cpp" fails sanity check
See `config.log' for more details.
*** Error code 1

bmake: stopped in /usr/pkgsrc/security/libgpg-error
WARNING: *** Please consider adding USE_LANGUAGES+=3Dc++ to the package
*** Error code 1

bmake: stopped in /usr/pkgsrc/security/libgpg-error

--- listing ends ---

The suggestion to add "USE_LANGUAGES+=3Dc++" to the Makefile fixes the
problem. Should I post the "mini-patch" to this list? There are several
more packages which fail this way. Is there a way to "tweak" the wrapper
so that g++ is called in a different way - or is the setting USE...
sufficent. The patch for the Makefile is attached to this mail.


A: Yes.
>Q: Are you sure?
>>A: Because it reverses the logical flow of conversation.
>>>Q: Why is top posting annoying in email?

Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename=patch
Content-Transfer-Encoding: quoted-printable

--- Makefile.orig       Sat Nov  4 09:21:19 2006
+++ Makefile    Sat Nov  4 09:21:26 2006
@@ -16,6 +16,7 @@
 USE_LIBTOOL=3D           YES
+USE_LANGUAGES+=3D         c++
 .include "../../mk/"


Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.1 (GNU/Linux)