Subject: Re: zope29 components
To: Takahiro Kambe <>
From: Brook Milligan <>
List: tech-pkg
Date: 10/12/2006 08:23:35
Takahiro Kambe writes:
 > Curretly, there are these version of Zope in pkgsrc:
 > 	pkgsrc/www/zope		Zope 2.2.2
 > 	pkgsrc/www/zope25	Zope 2.6.2
 > 	pkgsrc/www/zope29	Zope 2.9.4
 > 	pkgsrc/www/zope3	Zope 3.2.1
 > And Zope 2.2.x, 2.6.x, 2.9.x aren't completely upper compatible.
 > So, it should better that make zope product packages support these
 > multiple versions of Zope.

Are the packages compatible with, for example, all the zope 2.*
versions?   Or must there be a specific version of each package, one
per underlying zope version?

 > (I think that Zope packages should be made some restructuring.)

Do you have any specific suggestions?