Subject: Re: Splitting devel/mercurial
To: Thomas Klausner <>
From: Peter Schuller <>
List: tech-pkg
Date: 07/24/2006 20:57:05
> > I wanted to package cvs20hg in wip, but ran into the problem that
> > rcsparse (a dependency of cvs20hg) requires Python 2.4. cvs20hg requires
> > both rcsparse and the mercurial libraries; so if devel/mercurial has been
> > installed with Python 2.3, there is breakage.
> How about taking the easy way out of making mercurial only accept python24?

That certainly solves my particular problem.

I guess the only real situation where that might not be appropriate is if 
there are mercurial extensions that don't work with 2.4 for some reason.

If that's considered acceptable; fine by me. I just figured that my desire to 
package some other application in wip was not a very good reason to further 
restrict the mercurial package.

/ Peter Schuller, InfiDyne Technologies HB

PGP userID: 0xE9758B7D or 'Peter Schuller <>'
Key retrieval: Send an E-Mail to
E-Mail: Web: