Subject: gramps2 and python
To: None <>
From: Greg Troxel <>
List: tech-pkg
Date: 07/12/2006 19:52:03
Content-Transfer-Encoding: quoted-printable

I'm trying to build gramps2, and having trouble.  I'm using a pkg_comp
chroot with netbsd-3 sets on a current i386 box.  I'm using pkg_chk in
the chroot.  I started building a few days ago but tried gramps2 with
up-to-the-minute pkgsrc bits.

I have 1.19 of databases/gramps2/Makefile, and it sets
PYTHON_VERSIONS_ACCEPTED to 2.  But then the build looks for 23, and I
think that's because of the code in the bl3 files that checks for
threading.  It seems wrong for bl3 files to expand the list of
accepted versions.

Also, I wonder if it is time to set the default version to 24, since
23 seems troublesome for some things.

pkg_comp:netbsd-3.conf# make package
=3D> Checksum SHA1 OK for gramps-2.0.11.tar.gz.
=3D> Checksum RMD160 OK for gramps-2.0.11.tar.gz.
=3D=3D=3D> Installing dependencies for gramps-2.0.11
The following variables will affect the build process of this package,
gramps-2.0.11.  Their current value is shown below:

        * BDBBASE (defined)
        * BDB_TYPE =3D db1
        * FAMBASE (defined)
        * FAM_TYPE =3D fam
        * KRB5BASE (defined)
        * KRB5_TYPE =3D heimdal
        * SSLBASE (defined)

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=3D> Required installed package gettext>=3D0.10.35nb1: gettext-0.14.5 found
=3D> Required installed package pkg-config>=3D0.19: pkg-config-0.20 found
=3D> Required installed package x11-links>=3D0.25: x11-links-0.30 found
=3D> Required installed package py-gobject-shared>=3D2.10.1: py-gobject-sha=
red-2.10.1 found
=3D> Required installed package randrproto>=3D1.1.1: randrproto-1.1.2 found
=3D> Required installed package renderproto>=3D0.9.1: renderproto-0.9.2 fou=
=3D> Required installed package fixesproto>=3D3.0.0: fixesproto-3.0.2nb1 fo=
=3D> Required installed package xextproto>=3D7.0: xextproto-7.0.2 found
=3D> Required installed package xproto>=3D6.6: xproto-7.0.4 found
=3D> Required installed package yelp>=3D2.2: yelp-2.14.2 found
=3D> Required installed package gnome-vfs2>=3D2.8.0: gnome-vfs2-2.14.2 found
=3D> Required installed package scrollkeeper>=3D0.3.12nb2: scrollkeeper-0.3=
.14nb10 found
=3D> Required installed package py23-bsddb3>=3D4.3.3nb1: py23-bsddb3-4.4.2 =
=3D> Required installed package py23-imaging>=3D1.1.4: py23-imaging-1.1.5nb=
1 found
=3D> Required installed package py23-xml>=3D0.8.3nb1: py23-xml-0.8.4nb2 fou=
=3D> Required installed package py23-gnome2>=3D2.10.0: NOT found
=3D> Verifying package for ../../x11/py-gnome2
WARNING: Skipping -gnome2-2.12.4nb1:
WARNING: No valid Python version
ERROR: [] A package matching ``py23-gnome2>=3D2.10.0'' should
ERROR:     be installed, but one cannot be found.  Perhaps there is a
ERROR:     stale work directory for ../../x11/py-gnome2?
*** Error code 1

make: stopped in /usr/pkgsrc/databases/gramps2

        Greg Troxel <>

Content-Type: application/pgp-signature

Version: GnuPG v1.4.4 (NetBSD)