Subject: "gtk2+" vs. "perl" (was: CVS commit: pkgsrc/x11/gtk2)
To: Alistair Crooks <>
From: Matthias Scheler <>
List: tech-pkg
Date: 07/06/2006 08:34:24
On Wed, Jul 05, 2006 at 10:30:43PM +0100, Alistair Crooks wrote:
> > Log Message:
> > Add "perl" to list of requires tools because it used to generate a
> > ".c" file during the build. Bump package revision because resuming
> > a build broken by this problem did actually succeed and produced
> > an incomplete package.
> > 
> > Approved by Thomas 'wiz' Klausner.
> Thanks, Matthias - is there any way we could pre-generate the file,
> so that the dependency on Perl is not needed?

Eventually but there is really no point to that. The "glib2" package
which is one of the dependence of the "gtk2+" package requires the
"perl" package, too. It will therefore always be present on a system
when you try to build "gtk2+".

	Kind regards

Matthias Scheler