Subject: Re: Dependency pattern syntax
To: None <>
From: Hubert Feyrer <>
List: tech-pkg
Date: 05/26/2006 09:26:28
On Fri, 26 May 2006 wrote:
>> How about
>> 	php>=4.4<4.5
>> instead, which more precisely describes what is wanted?
> This works in this situation, but not sure if can be done in all cases.
> E.g. php-4.4p1 would match your pattern, but not the fnmatch style.

About this whole proposal:
I didn't really understand what the point of changing the complete syntax 
for our version specifier is. If it's just to allow ranges, then maybe 
that could be done within the current scheme, instead of changing 
everything and its mother.

That said:
May I suggest that this be deferred for now, and be part of some re-design 
of the pkg_install tools'n'stuff that's gonna happen for Summer-of-Code?

We'll be happy to have a look at a complete design specification, instead 
of random updates to random places "because you feel bored". :-)

  - Hubert