Subject: Re: Fwd: Is there a way to get X to work on an X800 Radeon on current/amd64?
To: None <>
From: Martijn van Buul <>
List: tech-pkg
Date: 04/20/2006 17:07:08
It occurred to me that Blair Sadewitz wrote in gmane.os.netbsd.devel.packages:
> I have used this Sapphire X800GTO card with Xorg on OpenBSD and it
> worked fine.  On NetBSD (HEAD 20060418 snapshot), neither XFree86 nor
> Xorg work.

I'm having similar problems getting my X300 to work.

> XFree86 simply complains that there are no valid devices, even if I
> manually specify the ChipID and BusID.

By "manually specifying the ChipID" I take it you mean "overriding the
ChipID with something XFree86 *does* support"? Trying to specify the original
ChipID doesn't work, as ChipID isn't used as a locator but to override the
probed chipset.

That's how I'm currently running XFree86 on it; I'm overriding the chipID,

	ChipId	    0x4E4A

(Which is an 9800something with an RV360 core (AGP), while my x300 uses an
RV370 core which is *alledgedly* similiar, minus PCIe vs AGP differences).

So far, it seems to work *knock on wood*, but it's far from optimal.

> Xorg I can get to get the device, and if I run Xorg alone, I can display the
> root window (not exactly awe-inspiring use of a $120 video card).  However,
> if I try to run startx or xinit, the X server dies with this message:
> (WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found
> /usr/pkg/xorg/bin/twm:  another window manager is already running. on screen 0?
> /usr/pkg/xorg/bin/twm:  unable to find any unmanaged video screens.
> X Error of failed request:  BadValue (integer parameter out of range for operati
> on)
>   Major opcode of failed request:  1 (X_CreateWindow)
>   Value in failed request:  0x20
>   Serial number of failed request:  35
>   Current serial number in output stream:  43

Yes; I'm with you there. Same problems.