Subject: Fwd: Is there a way to get X to work on an X800 Radeon on current/amd64?
To: None <>
From: Blair Sadewitz <>
List: tech-pkg
Date: 04/19/2006 21:20:06
I have used this Sapphire X800GTO card with Xorg on OpenBSD and it
worked fine.  On NetBSD (HEAD 20060418 snapshot), neither XFree86 nor
Xorg work.
XFree86 simply complains that there are no valid devices, even if I
manually specify the ChipID and BusID.  Xorg I can get to get the
device, and if I run Xorg alone, I can display the root window (not
exactly awe-inspiring use of a $120 video card).  However, if I try to
run startx or xinit, the X server dies with this message:

(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) foun=
/usr/pkg/xorg/bin/twm:  another window manager is already running. on scree=
n 0?
/usr/pkg/xorg/bin/twm:  unable to find any unmanaged video screens.
X Error of failed request:  BadValue (integer parameter out of range for op=
  Major opcode of failed request:  1 (X_CreateWindow)
  Value in failed request:  0x20
  Serial number of failed request:  35
  Current serial number in output stream:  43

Is there any way I can fix this?  I really would like to try running
NetBSD, and did not expect to have *MORE* problems with hardware
support than OpenBSD.  I am very impressed with the speed and really
would like to try it out, but I cannot use it if I cannot get X



P.S. Please reply to me and not just this list if responding.

"What is the practical application of a million galaxies?"

--Alan W. Watts