Subject: Re: [PATCH] qemu tap support broken on current 3.99.17
To: None <>
From: Luciano Rodrigues Furtado <>
List: tech-pkg
Date: 04/16/2006 17:45:30
Quentin Garnier wrote:
> On Sun, Apr 16, 2006 at 05:27:17PM -0300, Luciano Rodrigues Furtado wrote:
>> Quentin Garnier wrote:
>>> On Sun, Apr 16, 2006 at 09:43:55PM +0200, Hubert Feyrer wrote:
>>>> On Sun, 16 Apr 2006, Luciano R. Furtado wrote:
>>>>> qemu when started with -net tap is crashing on tap_open on 
>>>>> NetBSD-current, I had to apply the following patch to get it to work
>>>> What will this do on NetBSD 2.x and 3.0?
>>> It's a workaround, not a fix.
>> should I send-pr so somebody can provide a final solution later on?
> What qemu is this?  The one we have in pkgsrc doesn't have support for
> our clonable tap(4), and hopefully no NetBSD developer is responsible
> for code that doesn't check the return value of an ioctl() call.
That was just a workaround I tried , in order to get qemu working on 
current? because it crashes for me on tap_open! What am I  missing here?