Subject: Re: pkg_info: patch to create summary file
To: Hubert Feyrer <firstname.lastname@example.org>
From: Dieter Baron <email@example.com>
Date: 04/12/2006 02:03:23
> I have looked over your patch, and it seems fine.
Thank's for the review.
> The only thing that's not 100% clear to me is how the distinction between
> an 'installed' package and one in a package is made - the fname variable
> seems to be used here. If that assumption is right, maybe that should be
> documented (i.e. add a comment), or another variable with a better name
> could be used.
You're right, that was a quick hack to get the file name into
show_summary. None of the other show_* function use the file name.
I'll clean that up.
> In general, the code seems to be under-commented, esp. that in var.c -
> guessing what a function does is always painful to me.
Okay, I'll add function comments where missing.