Subject: Re: c++ h8300-hms cross-compiler
To: Hubert Feyrer <>
From: Osamu OISHI <>
List: tech-pkg
Date: 04/10/2006 13:50:41
> Was that a request for testing, or for committing to pkgsrc?
> If the former, I'd appreciate an explicit notice to commit the update
> once someone has tested it.
> (I'm happy to act as CVS frontend, but I cannot test this!)
>   - Hubert

I think that 3.1 is more stable than 3.4.3 as described in the previous mail. 
On the other hand, there might be the person who needs the function of 3.4 
in the usage of c++ and elf.
(It is difficult to make 3.1 correspond to elf)
The relation between h8300-hms-3.1 and h8300-hms-3.4.3 looks like the relation 
between gcc-2.95.3 and gcc-3.4.5 of pkgsrc.

It is uncertain whether to be able to use this compiler as a business tool, 
though a big problem is not found in my test of more than half a year for
h8300-hms-3.4.2 and h8300-hms-3.4.3. 

Though h8300-elf is necessary for using "ecos etc.", 
when the same program is compiled with a.out and elf, different operation might be found.
(It might be bugs of my programs, Makefile, or map file.)

My final demand is "testing", and I think that committing is premature. 
On the other hand, since there is a person who wants to use c++ or elf, 
it is accepted to commit or to update pkgsrcs.