Subject: Re: Forthcoming GNOME 2.14.0 changes
To: Jeremy C. Reed <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 03/28/2006 09:39:30
On 3/28/06, Jeremy C. Reed <> wrote:
> >       Updated print/poppler to 0.5.1 [jmmv 2006-03-25]
> >       Updated print/poppler-glib to 0.5.1 [jmmv 2006-03-25]
> >       Updated print/poppler-qt to 0.5.1 [jmmv 2006-03-26]
> This a development snapshot, not the latest stable poppler release.

Oh, I see.  By the way, I have some doubts about this update that I wanted
to ask you.

poppler-glib now needs cairo support (it is supposed to have a configure
flag to disable it, but then the glib support build breaks).

What I did was to enable the cairo backend in the poppler-glib package so
that this package installs now both things.  Not very clean, I know, but I
didn't create a different package (poppler-cairo) because all the cairo
backend enables at _installation_ time is an extra .pc files.  During the
build, things are compiled statically into the other libraries (the glib on=

Would you like to review it overall?

> Is this needed for GNOME?

I haven't really checked... will do.  GNOME 2.14.0 comes with evince
0.5.2, so I assumed it needed poppler 0.5.x without trying.

> (Thanks for updating this for me though.)

You're welcome.

Julio M. Merino Vidal <>
The Julipedia -