Subject: Re: BUILDLINK_DEPENDS.expat
To: Johnny Lam <firstname.lastname@example.org>
From: Todd Vierling <email@example.com>
Date: 03/23/2006 10:08:30
On Thu, 23 Mar 2006, Johnny Lam wrote:
> > The way it's currently handled in pkgsrc is, in short:
> > BUILDLINK_DEPENDS: *API* changes.
> > BUILDLINK_RECOMMENDED: *ABI* and/or security-related changes.
> > This is a really important distinction, and has made pkgsrc very flexible
> > for "power users". If we remove that distinction, we revert back to the
> > older incarnation of pkgsrc which forces the rebuild-the-world dances even
> > on those users who have the knowledge/experience to deal with such changes
> > in a more staged or progressive manner.
> If this is the case, I would rather we rename the variables to prevent any
> further confusion for developers or users:
> BUILDLINK_DEPENDS.* -> BUILDLINK_API_DEPENDS.*
> BUILDLINK_RECOMMENDED.* -> BUILDLINK_ABI_DEPENDS.*
If this is done, we may want a third one (BUILDLINK_SECURITY_DEPENDS?),
because that's the other reason for using RECOMMENDED today. Otherwise I'm
happy with this, because it does reflect the usage of these variables.
-- Todd Vierling <firstname.lastname@example.org> <email@example.com> <firstname.lastname@example.org>