Subject: Re: "libtool" generated shared objects under Mac OS X
To: None <>
From: Jed Davis <>
List: tech-pkg
Date: 03/20/2006 22:09:05 (Matthias Scheler) writes:

> Jed Davis <> writes:
>> Are they MH_DYLIB or MH_BUNDLE?  (file(1) should tell you.)
> tron@excalibur:~>file /usr/pkg/lib/gtk-2.0/2.4.0/loaders/
> /usr/pkg/lib/gtk-2.0/2.4.0/loaders/ Mach-O bundle ppc
>> The convention seems to be that the former should be named with
>> ".dylib" and the latter with either ".bundle" or ".so"
> So the above is named correctly and GTK+ is broken because it expects
> it to be called ".dylib"?

I believe so.  It's not a dylib, so it'd be misleading to name it ".dylib".

(let ((C call-with-current-continuation)) (apply (lambda (x y) (x y)) (map
((lambda (r) ((C C) (lambda (s) (r (lambda l (apply (s s) l))))))  (lambda
(f) (lambda (l) (if (null? l) C (lambda (k) (display (car l)) ((f (cdr l))
(C k)))))))    '((#\J #\d #\D #\v #\s) (#\e #\space #\a #\i #\newline)))))