Subject: Wide character supports in "ncurses" package
To: None <>
From: Matthias Scheler <>
List: tech-pkg
Date: 03/16/2006 12:20:51

I was recently contacted by user who suggested to link the "mutt" package
in "pkgsrc" against "ncurses" to get support for wide characters. I
suggested to him to use "PKG_OPTIONS.mutt= ncurses" which would achieve
exactly that.

It turned unfortunately out that our "ncurses" package doesn't support
wide characters. Fixing that is not difficult but it will break binary
compatibility according to the "ncurses" documentation.

I've checked my Fedora Core 3 Linux system at work and it seems to
provide both version of "ncurses" (with and without wide character
support). I wonder if we should adapt such a scheme for "pkgsrc", too?
And if we do should we provide two packages "ncurses" and "ncusersw"?

The later would probably be easier because I cannot see how one can
convince the "ncurses" distribution to build both "flavours" at
the same time.

	Kind regards 

Matthias Scheler