Subject: Proposed API changes before pkgsrc-2006Q1
To: None <tech-pkg@NetBSD.org, pkgsrc-users@NetBSD.org>
From: Roland Illig <rillig@NetBSD.org>
Date: 03/09/2006 17:03:51
since we are approaching another stable release of pkgsrc, the
probability of pullup requests decreases continuously, so this is a good
time for doing API changes that would be a burden to pull up to the
The REPLACE_INTERPRETER forces package authors to define variables whose
name starts with an underscore. And, even worse, this is _documented_ in
the pkgsrc guide. Since a few minutes, the variables REPLACE.* and
REPLACE_FILES.* can be used as aliases for _REPLACE.* and _REPLACE_FILES.*.
The SITES_* variables do not follow the naming conventions of
parameterized variables, in which the parameterized part is separated by
a "." instead of a "_".
Both changes work from now on. The remaining question is when to replace
the use of the old variables with the use of the new ones.