Subject: Re: databases/gnome-mime-data missing a dependancy
To: None <>
From: D'Arcy J.M. Cain <>
List: tech-pkg
Date: 02/21/2006 09:49:33
On Tue, 21 Feb 2006 11:47:50 +0100 wrote:
> On Mon, Feb 20, 2006 at 07:46:18PM -0500, D'Arcy J.M. Cain wrote:
> > This package would not build until I built textproc/p5-XML-Parser.  Not
> > sure if it should be DEPENDS or BUILD_DEPENDS.  I will add it as a
> > DEPENDS for now.  If that is wrong, go ahead and reduce it to
> Can you please give some details about how this fails for you?
> I'm not convinced it is really necessary, esp. as run time dependency.

Yes, I am not sure that it is a runtime dependency but I don't know the
package well enough to be sure.  Here is the output of the build.

checking for a BSD-compatible install... /usr/bin/install -c -o root -g
wheel checking whether build environment is sane... yes
Unknown `--run' option Try
--help' for more information configure: WARNING: `missing' script is
too old or missing checking for gawk... /usr/bin/awk checking whether
make sets $(MAKE)... yes checking for i386--netbsdelf-strip... no
checking for strip... strip
checking whether to enable maintainer-specific portions of Makefiles...
no checking for perl... /usr/pkg/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module
is required for intltool *** Error code 1

So it fails the configure step.  The failure implies that the package
requires the module.

I haven't made committed the change yet.  I will wait for further

By the way, would this kind of change require a PKGREVISION bump?

D'Arcy J.M. Cain <>