Subject: Re: php-mysql for MySQL 4.1x (as it was) instead of php5-mysqli?
To: None <>
From: Timo Schoeler <>
List: tech-pkg
Date: 02/07/2006 10:47:52
Thus spake on Mon, 6 Feb 2006 16:35:43 +0100:

> On Mon, Feb 06, 2006 at 04:04:41PM +0100, Timo Schoeler wrote:
> > in autumn 2005 i used databases/php-mysql for connecting to MySQL
> > 4.1x; unfortunately, pkgsrc-current builds php-mysql with a 3.23.x
> > ABI of MySQL, whereas connecting to MySQL4 would be possible using
> > php5-mysqli.
> This is a multi-version package. The packages it is using is
> controlled by MYSQL_VERSION_DEFAULT (50 or version installed) and
> PHP_VERSION_DEFAULT (4 or version installed). That applies to trunk,
> 2005Q4 might have different defaults.
> Joerg

hi, i got this from the documentation, too. it seems as if something on
that machine went wrong -- i flushed all pkgsrc stuff and started
again, this time it went okay. i'll dig into it as the first setup was
okay AFAICS.

thanks & sorry for the noise,