Subject: Re: gettext-0.14.5 for testing
To: None <firstname.lastname@example.org>
From: None <email@example.com>
Date: 02/04/2006 15:47:27
On Sat, Feb 04, 2006 at 03:30:27PM +0100, Thomas Klausner wrote:
> On Fri, Feb 03, 2006 at 09:37:00PM -0800, Jeremy C. Reed wrote:
> > Maybe we should use the package names as suggested by the gettext
> > developers (gettext-runtime and gettext-tools)?
> I support this suggestion.
I found the naming inconsistent and to obscure the intention. But since
the argument of renaming packages was brought up, we can do it properly.
We have four different blocks programs might care about:
(c) msgfmt and friends
(d) gettextize, m4 and related stuff
We can mostly ignore (b) in the discussion since it is pretty new and
independent of the rest. For pkgsrc (a) and (c) are the most import
packages, since they are used by almost anything.
What about naming them gettext-lib (haha), gettext-tools and gettext for
the rest? Splitting off most of the tools makes the integration into the
tools framework easier as well.