Subject: Re: ap-php4 depends on apache 1.3
To: Zafer Aydogan <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 01/18/2006 13:20:23
On Mon, 16 Jan 2006, Zafer Aydogan wrote:

> options as a binary, but it's kinda frustrating, that such a major
> package have all kind of modules like perl, python, ruby and much
> more, but is missing an essential one like php.

Since we do have several ap2-* packages, it does make sense (for now) to 
create a new package. Can you please create and test a www/ap2-php 

Copy the current www/ap-php directory to create www/ap2-php to get 
started. And modify to remove the .include "../../mk/" and us 
the following instead:
.include "../../www/apache2/"
.include "../../devel/apr/"

And change PKGNAME to have "ap2-" and fix the COMMENT and DESCR as needed.

Now if you you need a specific PHP, then consider making a package named 
ap2-php5 and ap2-php4 as needed. And get rid of the include of 
../../lang/php/ or set PHP_VERSION_REQD=4 or 5 as needed. (I 
don't know ... you will need to test this.)

Feel free to submit when ready.

 Jeremy C. Reed

 	  	 	 technical support & remote administration