Subject: Re: ap-php4 depends on apache 1.3
To: Zafer Aydogan <>
From: Lubomir Sedlacik <>
List: tech-pkg
Date: 01/16/2006 03:41:25
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Jan 15, 2006 at 11:38:22PM +0100, Zafer Aydogan wrote:
> The Binary Package ap-php-4.4.1nb3.tgz depends on Apache 1.3.x.  But
> when installing via pkgsrc it decides whether apache 1.3 or apache 2
> is installed and builds the correct module for apache 1 or 2.  But
> when installing as a binary, it tries to install apache1.3 although
> apache2 is installed.  I think it should be possible to install a php
> module for apache2 as a binary aswell.  There is currently no way to
> install the PHP Module for Apache 2 as a binary package.

you are confusing two issues here.

it *is* possible to install PHP Module for Apache 2 as a binary package.

such a package isn't provided on because currently the
bulk-build framework builds everything with the default set of options
and the default Apache version is 1.3.x.


-- Lubomir Sedlacik <salo@{NetBSD,Xtrmntr,silcnet}.org>   --

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.2 (NetBSD)