Subject: devel/apache-ant problem
To: None <>
From: None <>
List: tech-pkg
Date: 12/13/2005 14:03:36
I am having a problem with the devel/apache-ant package.  The problem
seems to be associated with executing the $JAVACMD command inside the
bin/ant wrapper program.  Here is a portion of the relevant file

     $NetBSD: patch-aa,v 1.1 2005/09/03 22:59:25 tonio Exp $

     --- bin/ant.orig	2005-05-19 14:37:16.000000000 +0200
     +++ bin/ant	2005-05-25 14:38:03.000000000 +0200
     @@ -117,7 +126,12 @@

      # set ANT_LIB location
     +# use ${PREFIX}/bin/java (wrapper)
     +if [ "$JAVACMD" = "" ] ; then
     +  JAVACMD=@PREFIX@/bin/java

      if [ -z "$JAVACMD" ] ; then
	if [ -n "$JAVA_HOME"  ] ; then

The problem is that there is no $PREFIX/bin/java installed by java,
and so the program fails.  If the definition of JAVACMD is changed to


it seems to work fine.

$PREFIX/bin/java used to be installed by the lang/java-wrapper
package, but that seems to have been removed.  No packages include
"./bin/java" in their PLISTs either.

Is there some other magic package that is supposed to be installed, or
do I have things misconfigured?  How is this supposed to work
correctly as written?

Thanks for your help.