Subject: Re: Firefox 1.5 package
To: Hubert Feyrer <>
From: Geert Hendrickx <>
List: tech-pkg
Date: 12/04/2005 20:24:13
On Sun, Dec 04, 2005 at 07:11:25PM +0100, Hubert Feyrer wrote:
> I gave your firefox pkgs in pkgsrc-wip two spins:
> 1) the xlib version works, but the default fonts are weird and going to
> the preferences and clicking on the tab from which I guess it leads to
> the font change dialogue crashes firefox reliably. There are also some
> other oddities in the UI, although rather minor ones.

The xlib and qt3 builds are experimental and not supported by Mozilla.  I
have to admit I only added those options for fun ("because I can") and out
of curiousity (like you :-)), but the resulting packages are not very
useful.  I'm considering to comment those options out, or at least add a
warning to them.  

> 2) I rebuilt for gtk1 after that, but that immediately dumps core upon 
> startup or displays this gem (while other X apps work fine!):
> 	chimay-bleu% firefox
> 	Xlib: connection to ":0.0" refused by server
> 	Xlib: XDM authorization key matches an existing client!
> 	Gtk-WARNING **: cannot open display: :0.0

Read the MESSAGE file. ;-)  

> Maybe I should give the Qt version a spin or *shiver* gtk2 ...

The qt3 version crashes as soon as you do *anything*. :-)  

The gtk1/gtk2 builds work perfectly fine though.