Subject: Re: how to best add libregex/nbcompat?
To: Jeremy C. Reed <>
From: Georg Schwarz <>
List: tech-pkg
Date: 11/28/2005 17:37:15
> On Sun, 27 Nov 2005, Georg Schwarz wrote:
> > In my attempt to finally get full IRIX 5.3 support to pkgsrc bootstrap I
> > attempted to build devel/bmake as a preliminary step.
> Just to let you know, pkgsrc/bootstrap/bootstrap doesn't use the pkgsrc 
> build system. So working on pkgsrc/devel/bmake/Makefile won't make any 
> changes or difference to the bootstrap.

I know, but it's a good start to figure out problems and try potential
Besides, as libregex is required by a number of other packages I would
really appreciate to learn how to best incorporate the respective
libnbcompat support in a Makefile. Is there a mechanism that pkgsrc can
use to determine whether libnbcompat is needed or not on a given platform
to implement the regex library?

Georg Schwarz  +49 178 8545053