Subject: Re: Another spamassassin problem
To: None <>
From: Klaus Heinz <>
List: tech-pkg
Date: 11/24/2005 21:29:12
mouss wrote:
> Martti Kuparinen a écrit :

> >Nov 22 16:36:09 p130 spamd[795]: Argument "a" isn't numeric in pack at 
> >/usr/pkg/lib/perl5/vendor_perl/5.8.0/Mail/SpamAssassin/ line 711, 
> ><GEN968> line 79.
> Is 5.8.0 the "intended" perl version? I'm not SA 3.1.0 was tested enough 
> with this.

The "5.8.0" in the path above most probably does _not_ come from an
installation of Perl 5.8.0.
After some recent changes to the way Perl is handled in pkgsrc all
pkgsrc modules get installed in the "vendor" branch in a directory where
they should be able to survive an upgrade of Perl itself. "5.8.0" only
indicates that some Perl 5.8.x created this directory and that the
modules are supposed to work with any later version of the Perl 5.8