Subject: starting package with /etc/rc.d
To: None <>
From: Iain Hibbert <>
List: tech-pkg
Date: 11/23/2005 11:47:19
   not sure if this is the right place (which list for rc.d problems?) -
I'm having trouble with a package not starting at boot time and cannot
quite work it out..

the package is mail/nullmailer which is a replacement for sendmail that
only forwards mail to a mail host (I use fetchmail/procmail for incoming)

1. I have nullmailer=YES set in my /etc/rc.conf file.

2. During bootup I get a "Starting Nullmailer." message but nullmailer is
not started and no messages are logged to /var/log/messages or the

3. "/etc/rc.d/nullmailer start" as root starts nullmailer just fine and
messages are logged to /var/log/messages as normal..

I fiddled in the source (C++ which I can't necessarily follow) and put a
printf("hello world") right at the beginning (which gets printed in case 3
but not 2) so I feel that nullmailer-send executable is NOT being started
at bootup but cant see why not.

I cant see a 'debug' option in the rc.conf subsystem, I tried adding "-x"
to the shell script /etc/rc.d/nullmailer but nothing is produced at boot

system and pkgsrc are both fairly current (updated both a few weeks ago
and updated most packages in the meantime - nullmailer 1.00 installed) and
I cant say that it ever worked or not, since previously I have been using
ppp dialup and would trigger mail sending manually in my ppp/ip-up script

any pointers?

my machine is a laptop and I'm doing some kernel devlopment so reboot
fairly often, otherwise I probably wouldnt have noticed..