Subject: problems building psi
To: None <>
From: Steven M. Bellovin <>
List: tech-pkg
Date: 11/06/2005 10:08:33
I just rebuilt psi with current pkgsrc, on up-to-date -current.  This 
was part of a massive rebuild to bring everything up to date, so all 
the precursors were the latest available as of yesterday.  Two 
generated source files, opt_appearance-ui.cpp and ui_about.cpp, 
wouldn't compile, because they were missing fontlabel.h and urllabel.h, 
respectively.  Both .cpp files are built from .ui files by uic; in both 
cases, the missing include files are listed in a <includehints> section.

I can build both files by deleting the offending #include statement, 
i.e., they aren't really needed in the first place.

It isn't clear to me if the problem is with the psi source, the 
-current environment, or the uic compiler, which is part of qt3-tools.  
I am indeed using a newer version of qt3-tools (3.3.5) than before.

		--Steven M. Bellovin,