Subject: Re: PHP include path and not returning full data
To: Jaromir Dolecek <>
From: Hisashi T Fujinaka <>
List: tech-pkg
Date: 11/04/2005 06:46:02
On Fri, 4 Nov 2005, Jaromir Dolecek wrote:

> On Thu, Nov 03, 2005 at 01:13:31AM -0700, Chris Jones wrote:
>> I just upgraded PHP to 4.4.1 (and then 4.4.1nb1) because of the recent
>> security advisory.  Now I'm seeing odd behavior where PHP scripts are
>> returning most, but not all, of their data.  For example, Gallery pages
>> show the top part of any given image, but not the bottom part.  Some PHP
>> scripts don't return any data at all.  I don't see anything in apache's
>> logs that looks relevant to this.
>> At the same time, I'm seeing PHP scripts which are unable to find files in
>> their include path.  This, at least, is showing up in apache's error_log
>> as the expected "unable to find file in this include path" sort of error.
>> Normally I'd try and track this down myself, but I'm doing remote admin
>> over a really lousy 'net connection.  Has anybody seen either of these
>> behaviors before?  Any hints on where to look first?
> I'd recheck if you updated all the extension (i.e. not make replace,
> but do make update). You are using Apache module version, right?
> Other then that, I'm out of ideas what might be wrong - I can just say
> PHP 4.4.1 works for me on similar 'gallery' like site I maintain, tho
> images are not generated by PHP; I don't see your problem with truncated
> PHP output.

I did a make update and my php sites are broken (not including scripts
from ./ path, apparently) on -current with php-4.4.1nb1. You might want
to try "gallery" or the svn version of "wordpress" (which are the apps
that break on my system.)


Hisashi T Fujinaka -
BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte