Subject: Re: gcc4.0
To: None <,>
From: Joerg Sonnenberger <>
List: tech-pkg
Date: 11/03/2005 12:45:07
On Thu, Nov 03, 2005 at 11:17:28AM +1030, Berndt Josef Wulf wrote:
> NetBSD-i386-current uses gcc version 3.3.3. This version is known to have a 
> several of bugs that forced me to make use of gcc version 3.4.4 from the 
> pkgsrc tree, e.g. pkgsrc/math/fftwf will segfault with sse optimized 
> binaries. I also have a local copy of gcc4-ada in order to participate in ADA 
> related projects.
> Can someone enlighten me why NetBSD is stuck on the buggy gcc-3.3.3 and didn't 
> upgrade to gcc-3.4.4?

Mostly (a) work and (b) testing on $X platforms. On the other hand from
my experience in DragonFly I believe GCC 3.4.4+ to be the most stable
compiler at the moment.