To: None <>
From: Roland Illig <>
List: tech-pkg
Date: 11/03/2005 11:40:46

how comes it that the use of INTERACTIVE_STAGE is discouraged by pkglint 
but still shows up in the pkgsrc guide?

The pkglint advice is to use BATCH and/or FOR_CDROM. As I don't know 
what these variables do, can someone please tell me if they are 
currently the Right Thing to do or if they should be deprecated, too?

And, by the way, this variable should be called INTERACTIVE_PHASES. 
First, it's a list (therefore the plural form). Second, the term "stage" 
is already used for the smaller steps of the build process, like 
{pre,do,post}-{configure,build,...} and should not be confused with the 
term "phase".