Subject: x11/gtk2: "Pango build with Cairo support..."
To: None <>
From: Andy Ball <>
List: tech-pkg
Date: 10/27/2005 18:29:35
I am unable to build x11/gtk2, which means I'm unable to use
applications that depend on it.  Here's the error message I

     checking Pango flags... configure: error:
     *** Pango not found. Pango built with Cairo support is
     *** to build GTK+. See for Pango

     *** Error code 1

     make: stopped in /mnt/annex/src/pkgsrc/x11/gtk2
     ===> There was an error during the ``configure'' phase.
     ===> Please investigate the following for more information:
     ===>      * config.log
     ===>      * /mnt/annex/src/pkgsrc/x11/gtk2/work/.work.log
     *** Error code 1

     make: stopped in /mnt/annex/src/pkgsrc/x11/gtk2

I have tried updating both graphics/cairo and devel/pango to
no avail.  I first noticed this problem a few days ago, but
I'm using pkgsrc that I checked out today.

     almond# uname -a
     NetBSD almond 1.6.1 NetBSD 1.6.1 (ALMOND-$Revision: 2.15
     $) #1: Wed Aug 11 19:09:58 GMT 2004
     root@almond:/usr/src/sys/arch/i386/compile/ALMOND i386

Is anybody else seeing this problem?  Constructive
suggestions or clues are welcome.

- Andy Ball