Subject: Re: CVS commit: pkgsrc/x11/blt
To: Min Sik Kim <>
From: Perry E. Metzger <>
List: tech-pkg
Date: 10/25/2005 13:52:01
Min Sik Kim <> writes:
> On Oct 7, 2005, at 11:20 AM, Perry E. Metzger wrote:
>> Indeed, there is a tkdesk 2.0 and 1.2 (in our tree) is deprecated.
>> We should just upgrade tkdesk.
> I wish we could, but tkdesk 2.0 doesn't run on NetBSD.  See PR pkg/
> 25274 for error messages.  So we need blt built with Tk 8.3 as long
> as we keep tkdesk 1.2.

I've finally gotten around to fixing the rest of the aftermath of the
blt upgrade (including my failing to fix the blt/ file
and ttt) and I'm now down to tkdesk.

I've read the PR you referenced. I'm sure we can fix that bug.

Could you apply all the patches you have to make tkdesk 2.0 build
and I'll finish debugging the package itself?

Also, it seems that the only program that is dependent on the older
itcl (i.e. [incr tcl]) is tkdesk. Rather than patching the older itcl,
might I suggest that we just upgrade it to one that runs under tcl/tk