Subject: Re: x11-links broken?
To: None <>
From: John D. Baker <>
List: tech-pkg
Date: 10/23/2005 14:59:00
I'm building a fresh set of packages from pkgsrc-current (updated 22 Oct.)
and when I tried to build wm/fluxbox, it couldn't find
"X11/extensions/render.h".  Hunting through the directory tree, it seems
that the symlink for that in x11-links-0.26 didn't get created.

Manually adding the symlinks in


was not sufficient as the package buildlink process still would not
create the links in


Manually adding the appropriate symlinks in

   .../ work/.buildlink/include/X11/extensions

allows the build to proceed.

Has anyone else seen this, or is it a fluke?  I'm building on sparc-current
from sources updated on or about 15 October.  Might I be tripping over
issues involved with the pkgsrc changeover from render to renderext? an
x11-links-0.26 installed on another machine on 12 October does not appear
to be missing the symlinks to


I'd originally tried to submit a logfile, but it was too big and my
message bounced.  Please find it here:


John D. Baker, KN5UKS                    NetBSD     Darwin/MacOS X
jdbaker(at)mylinuxisp(dot)com                 OpenBSD            FreeBSD
BSD -- It just sits there and _works_!