Subject: Xrender build failure (not finding render) on Darwin
To: None <>
From: Mark E. Perkins <>
List: tech-pkg
Date: 10/20/2005 19:52:53
Trying to update x11/Xrender, I get:

checking pkg-config is at least version 0.9.0... yes
checking for X_CFLAGS...
checking for X_LIBS...
checking for X... libraries /Volumes/NetBSD/pkg/xorg/lib, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for XTHREADS in Xlib... yes
checking for RENDER_CFLAGS...
checking for RENDER_LIBS...
configure: error: Package requirements (render >= 0.9) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the RENDER_CFLAGS and RENDER_LIBS environment
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
*** Error code 1

When I first got this error, I found that I had x11/render-0.8, but also
found that x11/render no longer exists. So I pkg_deleted x11/render and
installed x11/renderext-0.9, but I still get the above error....

This is with xorg from pkgsrc on MacOS 10.3.9, pkgsrc tree updated

Any clues?