Subject: Re: Failed to run acroread7 on NetBSD-current/i386
To: Ian Zagorskih <>
From: Geert Hendrickx <>
List: tech-pkg
Date: 10/17/2005 13:57:38
On Tue, Oct 11, 2005 at 07:26:53PM +0700, Ian Zagorskih wrote:
> I know this topic is probably getting booring for all but.. what about Acrobat 
> Reader 7.xx on NetBSD-3.99.xx/i386? The last successful versions pari i could 
> run was smth like acroread7-rc1/rc2 + NetBSD-3.99.3 or 5. Surely i had to 
> apply old good linuxemul hack like described in PR#30338 but finally it did 
> work some way and i was quite happy.  After thes times looks like 
> adding/fixing XPM loaders string 
> in /usr/pkg/emul/linux/etc/opt/gnome/gtk-2.0/gdk-pixbuf.loaders does not help 
> anymore and acroread crashes with same message like:
> ---cut---
> (acroread:1783): GdkPixbuf-WARNING **: Error loading XPM image loader: Image 
> type 'xpm' is not supported
> ---cut---
> I.e. the same problem discussed in PR#30338 and PR#30008 which are still 
> opened :( Any ideas?

The problem is in src/sys/arch/i386/include/vmparam.h.  If you downgrade
this file to revision 1.57 and rebuild your system, it works.