Subject: m4 and ctwm
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/13/2005 11:03:29
I don't use ctwm myself.

But I see that it uses m4.

And it has a MESSAGE.SunOS.

Maybe your package should get rid of the MESSAGE.SunOS.

And use:

USE_TOOLS+=	gm4:run
USE_TOOLS+=	m4:run

I don't know for sure, but if m4 is required, then maybe it should be a 
run-time dependency if the system does not provide it.

On Solaris, this defaults to:
TOOLS_PLATFORM.m4?=               /usr/ccs/bin/m4

You could use:

for the parse.c code that runs m4. Maybe have some CPP macro:

and update patch-ac to use M4?

  Jeremy C. Reed

  	  	 	 BSD News, BSD tutorials, BSD links