Subject: Re: python binary
To: Jeremy C. Reed <>
From: Jeroen Ruigrok/asmodai <>
List: tech-pkg
Date: 10/10/2005 20:11:12
-On [20051010 19:42], Jeremy C. Reed ( wrote:
>Can it be assumed that some python scripts can work with any version of 
>python we provide?

2.3 is compatible with 2.4.  2.2 is largely compatible with 2.3 and 2.4
depending whether some features are used or not (especially if it uses from
__future__ import ... to get the 2.[3|4] functionality).

Most scripts test for the appropriate version.

Jeroen Ruigrok van der Werven <asmodai(-at-)> / asmodai
Free Tibet! | | |
He who can, does.  He who cannot, teaches...