Subject: Re: Failed to build gtk2+-2.8.6
To: Ian Zagorskih <>
From: Jeroen Ruigrok/asmodai <>
List: tech-pkg
Date: 10/07/2005 13:33:43
-On [20051007 12:11], Ian Zagorskih ( wrote:
>checking pkg-config is at least version 0.9.0... yes
>checking for BASE_DEPENDENCIES_LIBS... 
>gnome-config: not found
>configure: error: Package requirements (glib-2.0 >= 2.7.1    atk >= 1.0.1    
>pango >= 1.9.0    cairo >= 0.9.2) were not met.

I also encountered this.

For some reason pkg-config invokes gnome-config in some ways when it cannot
match the version.

If you look at the configure you'll see:

pkg-config --cflags "cairo >= 0.9.2"

but for some reason I think something is going awry with the quoting, which
then gives the gnome-config issue.

Jeroen Ruigrok van der Werven <asmodai(-at-)> / asmodai
Free Tibet! | | |
Once upon a midnight dreary, while I pondered, weak and weary...